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Введение 

 

 В настоящем пособии рассматриваются вопросы динамики конструкций с 

применением CAE-пакета конечно-элементного анализа ANSYS. Материал 

пособия основывается на известных методах механики деформируемого твердого 

тела. Излагается методология решения разнообразных задач динамики 

конструкций: расчет статического напряженно-деформированного состояния, 

анализ собственных форм и частот конструкции, гармонический анализ, анализ 

переходных процессов в конструкциях, спектральный анализ.  

Материал изучается на конкретных практических примерах, в том числе 

проводится анализ напряженно-деформированного состояния створки головного 

обтекателя ракеты-носителя, анализ переходных процессов в панели солнечных 

батарей, спектральный отклик элементов космического аппарата на возмущение со 

стороны двигательной установки. Решение задач в пакете ANSYS описывается как 

подробная последовательность действий, к которым даются необходимые 

комментарии. В этой связи здесь следует отметить, что материал пособия 

сфокусирован именно на описании применения пакета ANSYS для указанного рода 

задач, а не на описании общетеоретических основ механики деформируемого 

твердого тела, которые с достаточной полнотой отражены в соответствующей 

учебной и методической литературе [1,2]. Необходимо заметить, что настоящее 

пособие не является справкой по командам пакета и также не предназначено для 

описания всех его многочисленных возможностей и параметров, включающих 

объемный по содержанию набор реализованных конечных элементов, 

разнообразные пути решения задач, и тем более, широкие графические 

возможности ANSYS как CAD-системы, позволяющей в полной мере осуществлять 

построение геометрической модели. Для последних целей будут полезны 

специализированные справочники, пособия [3], web-ресурсы и, безусловно, 

собственная справочная система пакета. 

Пособие предназначено для студентов (бакалавриата, специалистета, 

магистратуры), изучающих курсы «Динамика космических конструкций 

(космическое машиностроение)», «Модели и методы механики деформируемого 

твердого тела».  
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§1. Расчет статического напряженно-деформированного  

состояния створки головного обтекателя 

при инерциальном движении ракеты 

 

 Проведем исследование напряженно-деформированного состояния 

створки головного обтекателя (ГО) ракеты-носителя (РН) «Протон» (рис.1), 

закрепленного на ракете-носителе шарнирным креплением и пирозамком, и 

нагруженного пружинным толкателем (на самом деле на РН «Протон» 

установлена система пневмотолкателей). Будем полагать, что РН находится 

на участке инерциального движения с закрытыми створками, поэтому их 

напряженное состояние определяется условиями закрепления в шарнирном 

элементе, пирозамке и воздействием сжатого пружинного толкателя.  

 

Рис. 1. Схема ГО РН «Протон» 

 

1. Создаем новый файл для работы с задачей. Переходим в некий 

пользовательский каталог, например e:\ANSYS_job:   File->Change 

directory… указывая проводником на директорию e:\ANSYS_job. 
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Выбираем имя для файла задачи: File->Change jobname… сохраняя 

файл, например, с именем ―proton_GO‖.  

2. Создаем вид задачи: анализ на прочностные характеристики (свойства 

структуры): 

Preferences->structural 

3. выбираем тип конечных элементов для твердого тела: 

preprocessor->element type->add/edit/delete/-

>add-> solid, 10node92 ->close 

4. Устанавливаем свойства материала:  

Preprocessor->material props->material library-

>select units->SI (выбор единиц системы СИ) 

Preprocessor->material props->material models-

>favorites, linear static, linear isotopic-

>EX=2.e11,   PRXY=0.3 (модуль Юнга и коэффициент Пуассона, 

соответственно)->OK 

5. Создаем геометрию створки ГО. 

Сформируем плоское сечение створки ГО, а затем путем вращения 

вокруг продольной оси ГО создадим и саму створку как твердое тело. 

 Задаем ключевые точки: 

Preprocessor->modeling->create->keypoints->on 

working plane: 

Отмечаем ―WP coordinates‖, далее в поле задаем координаты x,y первой 

точки: 0,0 ->Enter, в том же поле попарно вводим координаты 

остальных точек, нажимая после каждой пары Enter: 

1.15, -2.31;        1.87, -4.42;             1.87, -7.89;           1.5, -10; 

1.77, -10;           2.14, -7.89;             2.14, -4.42;           1.15, -2.31;     0.27, 0. 

Всего построено десять ключевых точек с номерами с 1 до 10. 

 На основе построенных ключевых точек формируем многоугольник с 

вершинами 1-10:  

Preprocessor->modeling->create->areas 
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->arbitrary->through KPs. 

Далее последовательно мышью выделяются ключевые точки с 

номерами 1, 2, 3,…, 10, 1 и нажимается OK. После чего появляется 

сплошной многоугольник. 

 

Рис.2 

 Осуществляем построение створки ГО как твердого сплошного тела путем 

поворота полученного сечения вокруг оси Y на 180 градусов. Для этого 

формируем две вспомогательные ключевые точки с номерами 100 и 101 

(номера даны с запасом для избежания путаницы с принадлежностью их 

фигуре), из которых далее составим отрезок оси вращения. Создадим эти 

точки из командной строки (ANSYS command prompt): 

K,100,0,1 <Enter>;    K,101,0,-11 <Enter>; 

Далее осуществляем сам поворот: 

Preprocessor->modeling->operate->extrude 

->areas-> about axis; 
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Далее мышью указываем наш многоугольник, нажимаем OK. При 

появлении нового диалогового окна мышью выделяются точки 100 и 

101, символизирующие собой отрезок оси вращения, нажимаем ОК. В 

новом окне указываем угол 180 градусов, ОК. После этих операций 

формируется сплошная створка ГО.  

 Можно для наглядности немного повернуть координатные оси 

специальными кнопками на правой панели меню. Удобно также 

изменять положение осей координат (и построенного объекта) правой 

кнопкой мыши, удерживания клавиши ctrl. 

 

 

Рис.3 

 

6. Создаем сетку конечных элементов: 

Preprocessor->Meshing->Mesh->Volumes->Free. 
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Рис.4 

Сохраним наши построения в базе данных задачи: File->save as jobname.db. 

(SAVE_DB). 

Проведем анализ напряженно-деформированного состояния створки, 

закрепленной на РН традиционным способом посредством шарнирного узла 

на внешней части нижней кромки и пирозамка на нижней кромке, 

расположенного на расстоянии половины радиуса кромки (R) от плоскости 

контакта со второй створкой (см. рис.1). Будем считать, что после раскрытия 

пирозамка поворот створки вокруг шарнирного узла осуществляется 

пружинным толкателем с усилием 3 кН, располагаемым на внутренней части 

нижней кромки на расстоянии R/4 от плоскости контакта со второй створкой.  

7. Задаем граничные условия и нагрузки. 

Запрещаем узловые перемещения в шарнире в направлениях осей Y, Z 

и в пирозамке в направлениях X,Y,Z. 
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Solution->Define Loads->Apply->Structural -> 

Displacement-> On Nodes 

Выделяем мышью несколько узлов в середине нижней кромки, где, как 

мы считаем, расположен шарнирный элемент, вокруг которого створка 

будет вращаться в процессе раскрытия после освобождения от 

пирозамков. Нажимаем ОК, далее в диалоговом окне отмечаем UY, UZ и в 

поле VALUE ставим ноль, что означает запрещение перемещений 

указанных узлов в направлениях осей X, Z. Нажимаем ОК. 

 

Рис.5 

Далее аналогично закрепляем несколько узлов нижней кромки на 

расстоянии R/2 от плоскости контакта со второй створкой, дополнительно 

отмечая в диалоговом окне UX, т.е. считаем, что пирозамок фиксирует 

узлы во всех направлениях. 

 Теперь приложим силу пружинного толкателя. 

Solution->Define Loads->Apply->Structural-> 

Force/Moment 

Выделяем мышью несколько узлов нижней кромки на расстоянии R/4 

от плоскости контакта со второй створкой. Нажимаем ОК. В диалоговом 

окне выбираем направление силы толкателя FY и величину 3000 Н этой 

силы. ОК. 
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Рис.6 

В итоге получаем следующую расчетную схему (рис.7). Отметим, что 

можно также приложить симметричные закрепления и силу для второго 

пирозамка и второго толкателя, чего мы делать не станем. 

 

 

Рис.7 

8. Далее выбираем тип анализа: 

Solution->Analysis Type->New analysis->Static 

9. Запускаем расчет статического анализа напряженно-деформированного 

состояния: 

Solution->Solve->Current LS,   ОК. 
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Если расчет прошел без ошибок, то появится следующая форма: 

 

 

Рис.8 

10. Далее проводим анализ полученных результатов расчетов. 

Например, можно посмотреть полученные перемещения при деформации 

конструкции: 

General Postproc->Plot Results->Deformed 

Shape->Def+undeformed 

 

 

Рис.9. 

Как видно, максимальное перемещение равно 0.496Е-04 метров. 

 Напряжения внутри створки можно отобразить следующим образом: 

General Postproc->Plot Results->Contour 

Plot->Element Solu, 
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выбирая далее в диалоге (рис.): Sterss->von Mises stress, что будет 

соответствовать эквивалентным напряжениям экв , вычисленным по гипотезе 

энергии формоизменения Рихарда фон Мизеза: 

       
2 2 2 2 2 21

6
2

экв x y y z z x xy yz zx                   

 

Рис.10. 

Получим следующую картину распределения напряжений (рис.), из 

которой очевидно следует, что наибольшие их значения (0.101Е+07 Па) 

достигаются в зонах крепления створки и области приложения силы 

толкателя. 



 14 

 

Рис.11. 

Аналогичным путем можно построить картину распределения энергии 

напряжения, выбрав вместо ―Sterss->von Mises stress‖  в диалоге 

(рис.)  ―Energy->Strain energy‖): 
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Рис.12. 

Из последнего рисунка следует, что максимальные величины энергии 

напряжения достигаются в пирозамке. 
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§2. Расчет статического напряженно-деформированного 

состояния створки ГО при действии на РН перегрузок 

и набегающего потока 

 

Рассмотрим ситуацию, когда створки ГО закрыты, РН совершает 

вертикальное движение с перегрузкой 10g, при этом набегающий поток 

создает давление 10.е6 Па (10 атм.) на верхнюю коническую часть створок. 

Геометрия створки ГО и сетка конечных элементов созданы ранее. По 

сравнению с предыдущим расчетом (см. предыдущий пункт) для решения 

поставленной задачи необходимо изменить граничные условия и задать 

плотность материала для учета массовых перегрузок. 

1. Зададим плотность материала: 

Preprocessor->material props->material models. 

Выбирается ―Density‖ в поле ―Material models available  

-> Structural‖(рис.13). 

 

Рис.13. 

Величина плотности в единицах СИ (кг/м
3
) указывается в поле DENS. 

В нашем выбрана плотность алюминия 2700 кг/м
3
. Отметим здесь, что 



 17 

модуль Юнга материала остался прежним (2е11), что соответствует стали. В 

нашем случае таким сочетанием параметров мы имитируем прочностные 

характеристики композиционного материала створки ГО (истинные 

характеристики используемых в ГО композиционных материалов можно 

уточнить самостоятельно).  

2. Далее отменим все условия нагружения прежней задачи: 

Solution->Define Loads->Delete->All load data->All 

loads & opts 

3. Теперь задаем новые граничные условия. Так как створки ГО 

закрыты и подвергаются интенсивному симметричному внешнему 

воздействию, то из соображений симметрии следует запретить узловые 

перемещения по оси Z на плоскости контакта створок. Для этого 

выполним команду: 

Solution-> Define Loads-> Apply -> Structural-> 

Displacement -> On Areas. 

После этого появляется диалоговое окно (рис.14). Мышью и щелчком 

левой ее кнопки выделим оба торца створки ГО и нажнем ОК.  

 

Рис.14. 



 18 

Далее в следующем диалоговом окне укажем UZ и поставим ноль в 

поле ввода величины, что будет означать запрет узловых перемещений по 

направлению Z. 

 Нижняя часть ГО внешними воздействиями прижимается к последней 

ступени РН, а также крепится к ней шарнирным элементом и пирозамком. 

Такую ситуацию можно смоделировать полным закреплением узлов нижней 

грани и запретом их смещений по всем осям. Выполняем команду: 

Solution-> Define Loads-> Apply -> Structural-> 

Displacement -> On Areas. 

Мышью выделяем нижнюю грань створки (рис.15) и в появляющемся 

диалоговом окне выбираем All DOF (все перемещения) и указываем ноль в 

поле ввода. 

Рис.15 

Далее зададим внешнее давление на верхнюю коническую часть 

створки: 

Solution->Define Loads -> Apply -> Structural -> 

Pressure -> On Areas  
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Укажем мышью внешние части верхней конической поверхности 

створки (рис.16), нажмем ОК и в открывшемся окне введем в поле ―VALUE 

Load PRES value‖ значение 10.е6, что означает 1МПа (10 атмосфер). 

Рис.16 

Далее создадим условия массовой перегрузки 10g: 

Solution->Define Loads -> Apply -> Structural -

>Inertia -> Gravity -> Global 

и в открывшемся окне введем условия движения с ускорением 98.1 (м/с
2
) по 

оси Y (рис.17). 

 

Рис.17 

Все необходимые для расчета граничные условия и нагружения созданы.  

4. Запускаем вычисления: 
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Solution -> Solve -> Current LS 

После получения сообщения ―Solution is done‖ можно приступать к 

анализу результатов. 

 

5. Анализ результатов. 

Выведем эквивалентные напряжения по фон Мизесу: 

General Postproc->Plot Results->Contour Plot-> 

Element Solu, 

выбирая далее в диалоге  Sterss->von Mises stress. 

 

Рис.18 

Аналогично выбирая ―Sterss->Y-Component of stress‖ и 

―Energy->Strain energy‖ вместо ―Sterss->von Mises stress‖, 

получим картину распределения напряжений по направлению оси Y и 

энергии формоизменений (рис.19, 20). 
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Рис.19 

 

Рис.20 



 22 

 Выбирая General Postproc->Plot Results-> Vector Plot 

-> DOF solution, Translation U, получаем векторную картину для 

суммарных узловых перемещений. 

 

Рис.21 
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§3. Анализ собственных форм и частот колебаний створки 

головного обтекателя ракеты-носителя 

 

Проведем исследование собственных форм упругих колебаний 

створки, называемое также модальным анализом. 

6. Необходимо прежде сбросить результаты предыдущего расчета: 

Finish. 

7. Снимем все граничные условия и силовые нагрузки, чтобы 

посмотреть собственные формы свободных колебаний створки как 

упругого тела: solution->define loads->delete->all 

load data->all loads & opts 

8. Для модального анализа необходимо задать также плотность 

материала: 

Preprocessor->material props->material models. 

Выбирается ―Density‖ в поле ―Material models 

available  -> Structural‖(рис.). 

Величина плотности в единицах СИ (кг/м
3
) указывается в поле DENS. 

В нашем выбрана плотность алюминия 2700 кг/м
3
. Отметим здесь, что 

модуль Юнга материала остался прежним (2е11), что соответствует стали. В 

нашем случае таким сочетанием параметров мы имитируем прочностные 

характеристики композиционного материала створки ГО (истинные 

характеристики используемых в ГО композиционных материалов можно 

уточнить самостоятельно).  

 

4. Далее выбирается метод и опции решения: 

 

Solution->Analysis type->New Analysis->Modal (рис.22) 
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Рис.22 

Задаются опции анализа: Solution->Analysis type->Analysis 

Options  (рис.23).  Следует выбрать один из методов решения задачи на 

собственные формы (Block Lanczos, Subspace, PCG Lanczos,…) и ввести 

число искомых собственных форм (рис.23): в нашем случае их 15. 

.  

Рис.23 

5. Запускается расчет собственных форм:  
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Solution->solve->Current LS. 

По окончанию вычислений появляется сообщение ―Solution is done‖. 

6. Анализ результатов вычислений. 

 Просмотр полученных собственных частот: 

General Postproc->Result Summary (рис.24) 

 

Рис.24 

 Анимация собственной формы колебания. 

Сначала необходимо загрузить результаты расчета:  

General Postproc->Read Results->First Set. 

При этом в память загружаются результаты расчетов для первой 

формы. 

Если теперь выполнить команду General Postproc->Read 

Results -> Next Set, то загрузятся результаты для второй 

формы. Если опять выполнить ―Next Set‖, то загрузятся результаты 

для третьей формы и т.д.  

Результаты для последней (15-ой в нашем случае) формы можно 

загрузить, выполнив ―Last Set‖ (рис.25). 
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Рис.25 

Анимацию для «загруженной» в память формы можно выполнить 

следующим образом. Обращаемся в меню ―PlotCtrls‖->Animate->Mode 

Shape (рис.26) 

 

Рис.27 
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Далее в открывшемся диалоге нужно установить число кадров для анимации 

и временную задержку между ними (в нашем случае 20 и 0.5) (рис.28). 

 

Рис.28 

После этого появляется плеер ―Animation Contro…‖, с помощью которого 

осуществляется просмотр и анимация собственной формы (рис.29, 30). 

 

Рис.29 
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Рис.30 

Отметим здесь, что при исследовании собственных форм мы не накладывали 

никаких условий закрепления на створку. Пакет ANSYS при этом нашел 

первые шесть собственных форм колебаний створки как твердого тела с 

шестью степенями свободы (три линейные и три угловые). Формы упругих 

колебаний по этой причине начинаются с седьмой формы (с частоты 45.83 

Гц). Относительно шести первых («твердотельных») собственных форм, 

соответствующих им частот и их найденных ANSYSом величин (и почему 

они именно такие) мы не станем давать комментариев в силу того, что эти 

формы не имеют физического смысла при рассмотрении вопроса об упругих 

колебаниях. 
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§4. Линейный анализ потери устойчивости конструкции (Buckling) 

 

Выполним анализ устойчивости оболочечной конструкции, 

соответствующей форме ГО, находящейся под действием внешнего давления 

на коническую часть. Анализ устойчивости предполагает нахождение 

величины критической силы, при которой происходит возникновение новых 

(нетривиальных) форм состояний равновесия при учете работы внешних сил 

на деформационных перемещениях точек конструкции. Происходит так 

называемая потеря устойчивости, т.е. когда исходная форма равновесия 

меняется на другую вследствие увеличения силовых нагрузок до 

критического значения. На практике обычно определяют первую форму, 

которая и будет реализовываться при увеличении исходной нагрузки (силы) 

до своего первого критического значения. 

В ANSYS исследование на устойчивость конструкции осуществляется 

с предварительным проведением статического анализа.  

Выполним построение оболочечной конструкции, осуществим 

наложение необходимых граничных условий и нагружения (внешнего 

давления), и проведем статический анализ. 

1. Создадим новый файл задачи:  

File->Clear & start new… 

File->Change directory… e:\ANSYS_job\Buckling_GO.  

File->Change jobname… buckling_GO 

Укажем тип задачи: Preferences -> Structural 

2. Проведем выбор типа элементов и построение геометрии модели. 

Preprocessor -> Element Type -> Add/Edit/Delete -> add 

Далее в диалоговом окне (рис.) выбираем тип Shell (оболочка) и четырех 

узловой элемент Elastic 4node 63 (SHELL63) с шестью степенями 

свободы в каждом узле (все осевые и угловые смещения). 
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Рис.31 

Теперь следует установить толщину конечных оболочечных элементов: 

Preprocessor -> Real constants -> Add/Edit/Delete -> 

add 

Нужно ввести числовое значение (в нашем случае 0.265 метров) в поле TK(I), 

что будет означать равномерную толщину элемента. Отметим, что есть 

возможность задавать неравномерную толщину, указывая ее во всех четырех 

узлах. 

3.1. Строим первые пять ключевых точек (см. первый раздел), с 

координатами (0,0)…(1.5, -10). 

3.2. Соединяем ключевые точки линиями:  

Preprocessor -> Modeling -> Create -> Lines -> In 

Active Coord 

Далее мышью указываем пары ключевых точек, на которых строятся 

отрезки. 

3.3. Строим две дополнительные ключевые точки (0,1) и (0,-11). Эти 

точки нужны в качестве узлов отрезка вращения для получения 

поверхности. 

3.4. Осуществляем построение поверхности вращением: 

Preprocessor -> Modeling -> Operate -> Extrude -> 

Lines -> About Axis 
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Мышью выделяются все построенные отрезки –> OK –> мышью 

указываем две вспомогательные ключевые точки -> OK -> указываем 360 

градусов как величину угла вращения.  

На полученной поверхности создаем сетку конечных элементов: 

Preprocessor -> Meshing -> Mesh -> 

 Areas -> Free, Pick all, OK 

 

 

 

 

Рис.32 

4. Запрещаем узловые перемещения в узлах нижней кромки и 

накладываем внешнее давление на верхнюю коническую часть ГО: 
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Solution -> Define Loads -> Apply -> Structural -> 

Displacement  -> On Lines 

Выбираем мышью линии нижней кромки, ОК. Далее указываем All DOF (все 

степени свободы) и задаем в поле ввода ноль, ОК. 

Solution -> Define Loads -> Apply -> Structural -> 

Pressure -> On Areas 

Выбираем мышью все участки верхней конической поверхности, ОК. Далее в 

поле VALUE Load PRESS Value вводим 1 (Па), ОК. Единичное значение 

внешнего давления вводится для удобства определения критического его 

значения, при котором произойдет потеря устойчивости и будет реализована 

новая форма равновесия. Так при анализе устойчивости будет найден 

коэффициент, определяющий во сколько раз надо увеличить исходную 

силовую нагрузку, и следовательно, т.к. исходная нагрузка равна единице, то 

будет найдена именно критическая ее величина.  

5. Далее осуществляем запуск статического анализа: 

Solution  -> Analysis Type -> New analysis -> 

Static, OK. 

Далее выполняем команду: 

Solution  -> Unabridged Menu для вывода «несокращенного» меню 

в разделе Solution  -> Analysis Type. При этом в последнем 

появляется пункт  «Analysis Options». Выбираем этот пункт, после 

чего появляется следующее диалоговое окно (рис.33, 34): 
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Рис.33 

В последнем диалоговом окне нужно «добраться» с помощью скроллинга 

(мышью опуститься в непоказанную зону) до пункта «Stress Stiffness 

on prestress» и выбрать там значение  “Prestress ON”. OK. 
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Рис.34 

 Далее запускаем анализ: Solution -> Solve -> Current LS. 

Соглашаемся с предупреждениями и дожидаемся сообщения ―Solution 

is done‖. Можно также ознакомиться с сообщениями о полученном 

решении (рис.35): 

 

Рис.35 
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Итак, предварительный статический анализ для анализа устойчивости 

проведен. Далее закрываем окно с сообщениями и сразу выполняем пункт 

меню Solution -> Analysis Type -> New Analysis. 

Соглашаемся с предупреждением и выбираем пункт ―Eigen Buckling‖. 

ОК.  

 

Рис.36 

Eigen Buckling – это тип анализа, который в русскоязычной литературе 

называют линейным анализом устойчивости. При таком анализе уравнения 

равновесия составляются с учетом изменения геометрии конструкции в 

деформированном состоянии (для этого необходим уже проведенный расчет 

в рамках предварительного статического анализа). Работу внешних сил, 

обусловленную изменением геометрии конструкции, учитывают с помощью 

матрицы геометрической жесткости и снова приходят к задаче на 

собственные формы равновесия конструкции, при этом в качестве результата 

определяются новая форма равновесия и параметр нагрузки  - коэффициент, 

показывающий во сколько раз необходимо увеличить исходную нагрузку для 
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реализации новой формы равновесия. Вообще говоря, количество новых 

форм равновесия не ограничено. Однако считается, что после того как в 

процессе увеличения нагрузки до первого (наименьшего) критического 

значения конструкция получила новую первую форму равновесия, она 

признается аварийной и более не эксплуатируется. Поэтому важна именно 

первая форма, которая и реализуется на практике (вторая форма смогла бы 

реализоваться лишь с большим значением критической силы). 

6. В пакете ANSYS первая форма потери устойчивости и параметр 

критической нагрузки успешно определяются после следующих операций. 

После того как в конце 5-го пункта выбран новый тип анализа ―Eigen 

Buckling‖, необходимо определить его параметры: 

Solution -> Analysis Type -> Analysis Options, после 

чего появляется диалоговое окно (рис.), в котором выбираем метод решения 

―Block Lanczos‖, а в поле ―NMODE No. of modes to extract‖ 

указываем значение 1 (т.е. номер первой «извлекаемой» формы равновесия), 

ОК. 

 

Рис.37 

Выбираем пункт меню Solution -> Load Step Opts -> 

ExpantionPass -> Single Expand -> Expand Modes и в поле 
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―NMODE No. of modes to expand‖ (рис.38) вводим 1 (первая форма). 

ОК. 

 

Рис.38 

Далее запускаем расчет    Solution -> Solve -> Current LS.  

6.  Загружаем полученные результаты для обработки их 

постпроцессором: General Postproc -> Read Results -> 

First Set. 

7.  Выводим на экран первую форму потери устойчивости: General 

Postproc -> Plot Results -> Deformed Shape. 

Выбираем, например, опцию  ―Def shape only‖ или  ―Def + 

undeformed‖.  

 

Рис.39 
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Можно также пользоваться удобным инструментом для вращения и 

перемещения объекта на экране PlotCtrls -> Pan Zoom Rotate…:  

 

 

Рис.40 

На экране также представлена следующая числовая информация: 

FREQ =.374E+11;  DMX =.394074.  Это, соответственно, параметр 

критической нагрузки и максимальное узловое перемещение. Таким образом, 

критическое давление, при котором происходит потеря устойчивости по 

первой форме, равно 1*0.374E+11=374 ГПа, а  максимальное узловое 

смещение при этом 0.394 м.  

 Можно поменять схему закрепления нижней кромки ГО, разрешив 

шарнирные вращения в узлах (отказаться от All DOF и запретить только UX, 

UY, UZ). В итоге получим следующую схему закрепления (рис.41). 
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Рис.40 

Для последней схемы, повторяя аналогичные действия, можно 

получить следующую первую форму потери устойчивости, почти 

повторяющую предыдущий расчет (рис.41). 

 

Рис.41 

Как видно из результатов расчетов на прежней сетке конечных элементов для 

шарнирного крепления нижней  кромки ГО получены следующие значения 

критического давления и максимальные узловые перемещения: 361 ГПа и 

394 мм, т.е. критическое давление уменьшило свое значение на 13 ГПа, а 

узловые смещения практически не изменились. 
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§5. Гармонический анализ конструкции (Harmonic) 

 

Любое колебательное воздействие на конструкцию производит ее 

гармонический отклик. Гармонический анализ позволяет предсказать 

динамическое поведение конструкций, позволяя проверить, действительно ли 

они успешно преодолеют резонанс, усталость, и другие вредные эффекты 

вынужденных колебаний. 

Рассмотрим механическую систему с динамическим гасителем колебаний, 

предназначенную для уменьшения амплитуды колебаний каких-либо 

элементов (тел). На практике такие системы находят применение для 

подавления колебаний, станков с вибрирующими частями. Идея гашения 

колебаний хорошо видна их следующей структурной схемы механической 

системы (рис.42).  

 
Рис.42 

 

Колебания основного тела 1, на которое прикладывается гармоническое воздействие 

(от вибрирующих или вращающихся элементов), можно подавить за счет выбора 

соответствующих параметров пружин и массы гасителя 2. В этом случае 

динамический гаситель 2 будет способен «забирать» на себя колебания, т.к. он 

вовлекается в такой колебательный процесс, при котором деформирование 

дополнительной пружины развивает гармоническую силу, действующую на основное 

тело противоположно вынуждающей силе и уравновешивает ее. 

 Проведем частотный анализ подобной системы, состоящей из твердой 

плиты на четырех пружинах, крепящейся к неподвижному основанию и 
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гасителя, состоящего из собственной пружины, крепящейся к центру плиты и 

массы, на свободном конце. На плиту приблизительно в центре действует 

гармоническая сила. Схема системы, построенная далее в ANSYS, 

представлена на рисунке (рис. 43). 

 

Рис.43 

Итак, приступим к реализации поставленной задачи. 

1. Как и ранее сначала необходимо выбрать каталог и имя задачи, что 

описывалось выше. 

2.  Далее необходимо определить типы конечных элементов, которые мы 

будем использовать при построении системы. В нашем случае будет 

использоваться три типа элементов: для твердой плиты, для пружины, 

для массового элемента гасителя. 

Main Menu-> Preprocessor-> Element Type-> 

Add/Edit/Delete,  Add.  

Для пружинного элемента (тип 1) выбираем (скроллингом) "Combination" 

и справа указываем "Spring-damper 14" (рис.44). Apply. 
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Рис.44 

Для массового элемента гасителя (тип 2): "Structural Mass",   

"3D mass 21"  (рис.45).  

 

Рис.45 

Для твердотельного элемента плиты (тип 3): ―Solid‖, ―10node 92‖ (рис.46). 

 

Рис.46 

ОК. 
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3. Определяем наборы констант (Real Constants) для выбранных типов 

конечных элементов. 

Preprocessor-> Real Constants. 

Add, Type 1, OK.  

Выбираем COMBIN14. Задаем в поле (K) жесткость пружин крепления 

плиты к фундаменту: 1000 (Н/м). Мы создали набор констант set1.  Add.  

Снова выбираем COMBIN14. Задаем в поле (K) жесткость пружины 

гасителя: 2000. Add.   

Выбираем  MASS21. Вводим в поле Y 10 кг. OK. 

Для материала плиты вводим модуль Юнга = 2е11, коэффициент 

Пуассона=0.3, плотность материала устанавливаем=3000. (Material Props… - 

см. предыдущие пункты). 

4. устанавливаем как текущий тип конечных элементов твердотельный тип  

Main Menu-> Preprocessor-> Modeling-> Create-> 

Elements-> Elem Attributes.   Вводим 3 для типа элементов. 

С помощью построений прямоугольника и операции extrude…along axis (как 

и ранее) строим сплошной прямоугольный параллелепипед с главной 

диагональю {-0.15,0,-0.15}-{0.15,0.1,0.15}. 

1. Далее строим сетку элементов на параллелепипеде: 

Meshing -> Mesh>Volumes>Free (рис.47). 
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Рис.47 

2. Строим узлы для пружинных и массового элемента: 

Предварительно узнаем сколько узлов уже построено в рамках сплошного 

параллелепипеда:   List->Nodes->OK 

Выводится список узлов и их координат. Последний номер узла в нашем 

случае оказался равен 719, поэтому наши новые узлы будут иметь номера 

720 и т.д.  

Создаем узлы: Main Menu-> Preprocessor-> Modeling-> 

Create-> Nodes-> In Active CS. 

Узлы пружин крепления опорных пружин: 720 {-0.15,-0.15,-0.2}; Apply; 721 

{0.15,-0.15,-0.2}; Apply; 722 {0.15,0.15,-0.2}; Apply; 723 {-0.15,0.15,-0.2}; 

Apply;     узел для пружины-гасителя  724 {0,0,0.5} OK. 
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7. Строим пружинные и массовый конечные элементы: 

Пружина тип 1: Main Menu> Preprocessor> Modeling> Create> 

Elements> Elem Attributes. Задаем Set 1 для набора констант 

(рис.48).  

 

Рис.48 

Для формирования пружины «по двум концам» выполняем 

Preprocessor-> Modeling-> Create-> Elements-> Auto 

Numbered-> Thru Nodes.  

Чтобы увидеть узлы и пружинных и твердотельных элементов необходимо 

выполнить команду utility menu (располагается на самом верху): Plot->Nodes 

В графическом окне мышью указываем узел 720 и ближайший угловой узел 

плиты. ОК. Далее аналогично для остальных трех опорных пружин (узлы 

721, 722, 733 и соответствующие углы плиты). 

Формируем пружину гасителя: выполняем Main Menu-> 

Preprocessor-> Modeling-> Create-> Elements-> Elem 

Attributes. 

 Устанавливаем набор констант Set 2 (аналогично рис.48).  



 46 

Preprocessor-> Modeling-> Create-> Elements-> Auto 

Numbered-> Thru Nodes.  

Выбираем мышью узел 724 и центральный узел плиты. OK. 

Чтобы увидеть сами пружинные и твердотельные элементы необходимо 

выполнить команду utility menu (располагается на самом верху): 

Plot->Elemets. В итоге получаем следующую систему (рис.49). 

 

Рис.49 

Строим массовый элемент-гаситель колебаний 

Выбираем Main Menu-> Preprocessor-> Modeling-> Create-> 

Elements-> Elem Attributes. Выбираем для поля ―Element type 

number‖ MASS21 и устанавливаем set 3 как набор параметров ―Real constant 

set number‖ (рис.50). 
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Рис.50 

Строим сам массовый элемент: 

Preprocessor-> Modeling-> Create-> Elements-> Auto 

Numbered-> Thru Nodes. Мышью указываем узел 724 (он же 

свободный конец пружины), в котором хотим разместить массовый элемент. 

OK. 

8. Накладываем закрепления и внешнюю силу, которая считается 

гармонической (частота силы будет выбираться из диапазона, который мы 

укажем позднее). 

Закрепляем All DOF  узлы 720-723.  Закрепляем узел 724 по UY, UX, 

разрешая колебания только по Z (процедура закрепления описывалась выше).  

Прилагаем силу:  Solution-> Define Loads-> Apply-> 

Structural-> Force/ Moment-> On Nodes. 

  Щелкаем мышью в узле, где хотим приложить силу (на плите ближе к 

центру). OK.   Указываем величину силы и направление: поле "FY", значение 

―-10000‖ OK. 

В итоге получаем следующую модель (рис.51): 
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Рис.51 

9. Выполняем анализ. 

Solution-> Analysis Type-> New Analysis. 

Выбираем тип анализа "Harmonic". OK. 

Настраиваем опции анализа: 

Solution-> Analysis Type-> Analysis Options: 

"Full",  "Amplitud + phase" (см. рис.52) 
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Рис.52 

Выбираем опции вывода внутренних результатов: 

Solution-> Load Step Opts-> Output Ctrls-> Solu 

Printout: 

"Last substep" (последний подшаг). OK. 

Задаем диапазон частот, для которых будет проходить анализ. Т.е. 

задаются величины частоты, которые последовательно назначаются как 

частоты вынуждающей гармонической силы (на каждом шаге ищется отклик 

на определенную частоту из указанного диапазона): 

Solution-> Load Step Opts-> Time/Frequenc-> Freq and 

Substeps. 

Введем  0 и 10 (Гц) для диапазона частоты вынуждающей силы. 

Введем число подшагов: 100. 

Одним щелчком выберем "Stepped" для «пошагового» изменения 

граничных условий (в нашем случае только частоты вынуждающей силы). 

OK. 

Теперь запускаем расчет:  Solution-> Solve-> Current LS. 

10. Проведение анализа результатов. 

Выбираем построцессор анализа временных зависимостей (его в 

ANSYS также называют POST26):  TimeHist Postpro 

Выбираем пункт для задания интересующей нас зависимости от 

времени. Имеется в виду предварительное создание переменной (в смысле 



 50 

программирования) для некоторой исследуемой величины, зависящей от 

времени, например, перемещение по оси X для узла номер N. 

Выполняем TimeHist Postpro -> Define Variables.  

Щелкаем мышью Add. Выбираем (это стоит по умолчанию в виде 

выбранной радио-кнопки) ―Nodal DOF result‖, что означает наш 

дальнейший выбор просмотра результатов узловых перемещений. В окне 

модели щелчком мыши указываем на узел плиты с номером 439 (к нему 

прикреплена пружина гасителя). OK. После этого заполняем новую 

появившуюся форму (рис.53). Номер формируемой переменной будет 2 (1 

занято в ANSYS для времени или, как в нашем случае, частоты). В поле 

―user-specified label‖ можно ввести пользовательское название для 

определенной переменной; в нашем случае мы введем ―VIBR_439_UZ‖. В 

правом поле выбирается какое именно перемещение нас интересует: UZ. 

 
Рис.53 

Можно аналогично создать еще несколько переменных. Их номера 

будут 3, 4, … Мы создадим еще одну переменную для просмотра результатов 

перемещения  UZ узла  724 (массы на свободном конце пружины гасителя). 

Эта переменная будет иметь номер 3, и мы назовем ее ―VIBR_724_UZ‖. 

Далее можно вывести графики для созданных переменных.  

Предварительно настраиваем окно графика, выбирая в верхнем меню 

PlotCtrls-> Style-> Graphs. Далее пролистываем до "X and Y 

lines". OK. 
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Теперь строим графики: TimeHist Postpro> Graph Variables 

В появившейся форме (рис.54) вводим 3 в первое свободное поле ―1st 

variable to graph‖, что означает, что мы вибираем график для переменной с 

номером 3. 

 

Рис.54 

Отметим здесь, что если заполнить номерами сформированных 

переменных другие поля (―2nd variable to graph‖ и т.д.), то в окне вывода 

будет построено несколько графиков (для каждой запрошенной переменной). 

В нашем случае выводится следующий график для амплитудно-частотной 

характеристики (АЧХ) колебаний по оси Z узла 724 (массы гасителя): 
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Рис.55 

Аналогично строится АЧХ колебаний по оси Z узла плиты 439: 

 

Рис.56 

Из сравнения результатов видно, что обе АЧХ практически  идентичны 

и, следовательно, при таком способе приложения вынуждающей 

гармонической силы отклик обоих узлов происходит на одинаковых частотах 

– примерно 2 и 3.3 Гц. 
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Рассмотрим еще один случай. Пусть гармоническая сила 1000 Н в 

направлении Z действует на тело 2, которое мы считали ранее гасителем. 

Сила приложена в узле 439. Пусть пружина «гасителя» имеет жесткость 1000 

(выбираем в пункте real constants->add/edit/delete->set2, 

edit и ставим 1000 в поле K), пружины опор  - 10000. Пусть также имеется 

действие гравитационной перегрузки 10 по Z (solution->define 

loads-inetia->gravity->global->). 

 

Рис.57 

Расчетная схема в этом случае имеет вид: 

 

Рис.58 

Проводя исследования, подобные описанным выше, получим 

следующие АЧХ колебаний по Z для узлов 439 и 724 (рис.59) 
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Рис.59 

Из последних результатов исследований видно, например, что силовое 

гармоническое воздействие на диапазонах частот 0.1-2 Гц, 2.5-3.2, а также 3.6 

и выше почти не оказывает влияния на плиту (узел 439), что видно по 

амплитуде колебаний, близкой к нулю. Напротив, на частотах 2.2 и 3.4 Гц 

происходит рост амплитуды «отклика» плиты на гармоническое воздействие. 

Последние частоты опасны для эксплуатации системы.  

Таким образом, на рассмотренном примере проведен частотный 

(гармонический) анализ отклика системы на периодическое внешнее 

возмущение.  
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§6. Анализ переходных процессов в конструкции 

Динамический анализ переходных процессов предназначен для 

определения динамического отклика конструкции при действии на нее 

нагрузок, зависящих от времени. Этот анализ используется для исследования 

изменяющихся во времени деформационных перемещений, напряжений и 

сил в качестве отклика конструкции на какие-либо комбинации статических, 

кратковременных и гармонических нагрузок. При этом рассматривается 

интервал времени, на котором принципиально важным является учет 

инерционных сил и эффектов демпфирования.  

Отметим, что если при проведении анализа можно отказаться от учета 

инерционных сил в конструкции и сил конструкционного демпфирования, то  

в этом случае выполняют обычный статический анализ, описанный в 

параграфе 1.  

Основными уравнениями, изучаемыми при анализе переходных 

процессов являются следующие уравнения: 

          ( )M u C u K u F t    , 

где [M] - матрица масс, [C] – матрица коэффициентов сил демпфирования, 

[K] – матрица жесткости,{u} – вектор узловых перемещений, {F(t)} – вектор 

узловых сил. 

В некоторый дискретный момент времени t, это матричное 

дифференциальное уравнение может быть рассмотрено как уравнение 

статического равновесия, если принять в качестве статических нагружений 

также силы инерции и силы демпфирования. ANSYS использует метод 

Ньюмарка (Newmark) интегрирования по времени или улучшенный метод, 

называемый HHT-метод для решения указанного уравнения в дискретные 
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моменты времени. Интервалы изменения значения времени t называют 

шагом интегрирования по времени.  

Имеется возможность проведения анализа переходных процессов тремя 

методами: 1). Full,    2). Reduced,   3). Mode superpos’n. 

1). Full – это самый главный метод проведения анализа. Он позволяет 

учитывать разного рода нелинейности (пластичность, большие перемещения, 

большие напряжения) и использует «полные» матрицы системы без всякого 

рода аппроксимаций. И перемещения и напряжения вычисляеются 

одновременно. Недостатком метода является его требование к ресурсам 

компьютера и самый длительный расчет. 

2). Reduced – этот метод «понижает» проблему размерностей, 

используя уплотненные матрицы. ANSYS использует процедуру Guyan 

Reduction уплотнения матриц, на чем мы не будем останавливаться. Этот 

метод более быстрый с вычислительной точки зрения, но обладает рядом 

ограничений на использование нелинейностей и некоторых видов 

нагружений. 

3). Mode superpos’n – этот метод для определения отклика 

конструкции использует разложения по собственным формам колебаний. Он 

более быстрый, чем оба предыдущих метода, но также имеет ряд 

ограничений на использование нелинейностей.  

Рассмотрим использование метода full – самого эффективного метода 

анализа переходных процессов. 

Прежде всего необходимо пояснить одно из самых важных понятий, 

необходимых для проведения анализа переходных процессов в ANSYS – шаг 

нагружения ―Load Step‖ (LS). Пусть конструкция подвергается некоторому 

силовому воздействию так, что прикладываемая сила линейно достигает 
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своего конечного значения за конечный промежуток времени и далее не 

изменяется (рис.60). 

 

Рис.60 

В этом случае можно считать, что в начальный момент времени сила 

была равна нулю. Это начальный шаг нагружения номер один. Далее сила 

имеет временной интервал своего линейного роста до конечного значения – 

это второй шаг нагружения, и т.д. Вообще говоря, мы собирались описывать 

ситуацию, когда сила начинала расти непосредственно с момента t=0, но в 

ANSYS первый шаг нагружения должен «хоть сколько-нибудь длиться» во 

времени, например 0.001 с (по умолчанию это 1с). В этой связи для первого 

шага нагружения (когда была нулевая сила) нужно назначить некоторое 

время t1. Далее для второго шага назначают время t2. И в нашем случае 

именно на втором шаге нагружения происходит линейный рост величины 

силы. 

Очевидно, что можно моделировать любую зависимость силы от 

времени, заменяя ее на серию коротких участков шагов нагружения с 

линейным изменением величины силы. 

Анализ переходных процессов собственно и описывает отклик системы 

на такое временное «переходное» силовое воздействие, поэтому в ANSYS 

анализ сводится к назначению и расчету серии шагов нагружения. 
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Итак, рассмотрим переходный процесс в конструкции, 

представляющей собой прямоугольную пластину из аллюминия, консольно 

закрепленную за одну из своих сторон. Длина, ширина и толщина пластины 

соответственно равны 0.8, 0.3 и 0.001 м. На одну из свободных вершин по 

перпендикуляру к пластине действует сила, растущая с нулевого значения до 

1 Н за 5с.  Проследим за колебаниями на  интервале времени 10 с второй 

свободной вершины пластины. 

1. Как и ранее назначаем какие-либо имена каталога и задачи. 

2. Назначаем тип конечных элементов SHELL63 (см. параграф 4). 

3. Назначаем константы для конечных элементов: Real Constant -> 

Add/Edit/Delete -> …TK(I)=0.001 (рис.61), что означает толщину. 

(сформирован набор параметров set1) 

 

Рис. 61 

4. Назначаем свойства материала (см. предыдущие параграфы): 

Мщдуль Юнга = 7е10, коэффициент Пуассона = 0.3, плотность = 

2700 (кг/м
3
). 

5. Рисуем прямоугольник: Modeling - >Create -> Areas -> Rectangle -> 

By Dimensions (рис.62) 
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Рис.62 

6. Строим сетку конечных элементов: Meshing -> Mesh -> Areas ->free 

 

Рис.63 

7. Выбираем новый тип анализа: Solution -> Analysis type -> New 

Analysis 

 

Рис.64 
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И выбираем метод full (рис.65) 

 

Рис.65 

8. Убеждаемся, что пункт меню Solution -> Unabridged menu 

(несокращенный) был выполнен и получил статус abridged menu. 

Тогда будут доступны некоторые скрытые изначально пункты. 

9. Задаем закрепления All DOF для нижней стороны (вершины {-0.15,-

0.4}-{0.15,-0.4}) прямоугольника (см. пред. параграфы). 

10.  Начинаем формировать условия первого шага нагружения: 

Во-первых, зададим силу по Z в узле вершины {-0.15,0.4}, причем ее 

величину положим равной нулю: Solution -> Default loads -

> Structural -> Force/Moment -> On Node … FZ=0. 

Во-вторых, выбираем временные параметры первого шага 

нагружения. 

Выполняем Solution -> Analysis Type -> Sol’n 

Controls и назначаем Time at end of loadstep = 0.001 и 

Time step size = 0.001 (при включенном выборе радио-кнопки 

Time increment) (рис.66) 
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Рис. 66 

Далее выполняем Solution -> Load Step Opts -> 

Output Ctrls -> Solu Printout  и выбираем Every 

substep (рис. 67) 

 

Рис.67 

Solution -> Load Step Opts -> Output Ctrls -> DB/ 

Result file и выбираем Every substep (рис. 68) 
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Рис.68 

Выполняем еще одну временную настройку: Solution -> Load 

Step Opts -> Time/ Frequenc -> Time-Time step и 

назначаем длительность первого шага нагружения и шаг его 

итегрирования, равными 0.001 (рис.69). Оставляем радио-кнопку 

ramped (наклонный), что означает дальнейшее изменение параметров 

нагружения по линейным законам до величин, которые мы укажем на 

следующем шаге нагружения. 
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Рис. 69 

Теперь первый шаг нагружения готов. Запишем его параметры файл, для 

чего выполним: 

Solution -> Load Step Opts ->Write LS File 

 и дадим ему имя-номер 1 (рис.70) 

 

Рис.70 

11. Формируем второй шаг нагружения: 

Назначаем силу по Z в вершине прямоугольника с величиной 1000 Н 
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(та, что на первом шаге была равна нулю). 

Далее задаем временные параметры второго шага нагружения: 

Solution -> Load Step Opts -> Time/ Frequenc -> 

Time-Time step и назначаем длительность второго шага 

нагружения 5 с и шаг его итегрирования 0.01 (рис.71). 

 

Рис. 71 

Запишем его параметры файл: 

Solution -> Load Step Opts ->Write LS File 

 и дадим ему имя-номер 2 (рис. 72) 

 

Рис.72 
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12. Задаем третий шаг нагружения. Этот шаг, собственно, является тем 

интервалом времени, на котором происходит «выравнивание» 

переходного процесса. Сила уже приняла конечное значение и ее 

модифицировать не надо. Нужно лишь указать длительность шага: 

Solution -> Load Step Opts -> Time/ Frequenc -> 

Time-Time step . Зададим ее равной 10 (рис.73), а шаг 

интегрирования возьмем 0.1. 

 

Рис.73 

Запишем параметры третьего шага нагружения в файл: 

Solution -> Load Step Opts ->Write LS File 

 и дадим ему имя-номер 3 (рис.74) 

 

Рис.74 

Все шаги нагружения (у нас их три) готовы. 

13. Запускаем анализ: Solution -> Solve -> From LS Files 

И указываем (рис.75) номер стартового шага нагружения (LSMIN) как 

1, последнего шага (LSMAX) как 3 и ставим 1 в поле LSINC, что 

означает последовательный прирост на 1 в имени-номере файла шага 
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нагружении для последовательного их расчета. 

Если все выполнено корректно, то запустится расчет и в итоге появится 

сообщение ―Solution is done‖.  

После этого необходимо выполнить Finish. 

Расчет закончен. Приступаем к анализу результатов. 

14. Как и гармоническом анализе, можно задать переменную и 

построить для нее график: 

Main Menu -> TimeHist Postpro -> Define Variables,  

Add;  Nodal DOF result. OK. 

Мышью указываем свободную вершину пластины (вершина {0.15,0.4}). 

Выбираем UZ. При этом создается переменная номер 2. 

Далее, как и в предыдущем параграфе, строим график для 2-ой 

переменной: Main Menu -> TimeHist Postpro -> Graph 

Variables.  

 

Рис.76 

Последний рисунок демонстрирует переходный процесс, в котором 

свободная вершина пластины перемещается в зависимости от времени.  

Можно также воспользоваться основным постпроцессором для 



 67 

визуализации деформационной картины пластины в целом после 

какого-либо шага нагружения. Например, выберем картину после 

второго шага: General Postproc -> Read Results -> By 

Load Step и ставим номер 2 для шага нагружения (рис.77) 

 

Рис.77 

Выполняем  General Postproc -> Plot Results -> 

Deformed Shape (рис. 78) 

 

Рис.78 
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Напряжения в пластине: General Postproc -> Plot Results 

-> Contour Plot -> Nodal Solu -> stress -> von 

Mises 

 

 

Рис.79 

Можно посмотреть картину распределения вращательных ускорений: 
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General Postproc -> Plot Results -> Contour Plot -> 

Nodal Solu ->  

 

Рис.80 

 

Рис.81 
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Пример проведения анализа переходных процессов завершен. 

В заключение отметим, что существует возможность 

исследования переходных процессов в конструкциях за счет изменения 

инерционных параметров, например, когда задано исходное 

вращательное ускорение, которое убывает до какой-либо величины. 

Это также касается и скоростей. Возможен анализ при совместном 

действии ускорений и сил. 

Для иллюстрации последнего замечания проведем расчет уже 

использованной консольно закрепленной пластины, когда ее связанная 

система координат ускоренно вращается в глобальной инерциальной 

системе.  

Пусть пластина находилась в начальный момент времени во 

вращательном движении вокруг оси X с ускорением 10 (1/с), которое 

линейно убывало до нуля за 5 с. 

Разместим дополнительно на незакрепленной вершине пластины 

балочный элемент (материал алюминий, длина 0.1 м, площадь 

поперечного сечения 0.000004 м
2
, моменты инерции поперечного 

сечения 8Е-9 м
4
), на конце которого находится точечная  масса 0.05 кг.  

Чтобы построить балочный и массовый элементы необходимо 

добавить в набор конечные элементы Beam –3D elastic 4 

(BEAM 4) и Structural mass – 3D mass 21. Для этого 

выполняем команду Preprocessor -> Element type -> 

Add/edit/delete… (add) 

Назначаем параметры для новых типов элементов: 

Real Constant -> Add/Edit/Delete…  

Выбираем add, BEAM4 и заполняем поля: 

AREA = 4e-6 (площадь поперечного сечения); 

IZZ=8e-9; IYY=8e-9; OK; (сформирован набор параметров set2). 

Выбираем add, MASS21и заполняем поля: 
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MASSX=0.05; MASSY=0.05;MASSZ=0.05, т.к. масса в 

направлениях одна и та же; ОК; (сформирован набор параметров set3). 

 

Теперь  создаем узел с номером 1000 (с запасом): 

Preprocessor -> Create -> Nodes -> In Active CS… 

 

Рис.82 

Переключаем тип элементов на BEAM4:  

Preprocessor -> Create -> Elements  -> Elem Attributes… 

BEAM4; real Constant Number Set 2. 

Переключаем вид экрана на вывод узлов (главное меню): Plot -> Nodes 

Строим балочный элемент: Preprocessor -> Create -> 

Elements  -> Auto numbered -> Thru nodes и мышью указываем 

на узел 1000 и узел в углу пластины.  

Переключаем тип элементов на MASS21:  

Preprocessor -> Create -> Elements  -> Elem Attributes… 

MASS21; real Constant Number Set 3. 

Строим массовый элемент: Preprocessor -> Create -> 

Elements  -> Auto numbered -> Thru nodes и мышью указываем 

на узел 1000. 

Переключаем вид экрана на вывод элементов (главное меню): Plot -> 

Elements. 
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Рис.83 

Расчетная модель модифицирована, к пластине прикреплены балочный 

и массовый элементы. Теперь переходим к расчетам. 

Также как в предыдущем расчете у нас будет три шага нагружения, но 

вместо растущей силы (как рассматривалось выше) в качестве нагрузок 

будем задавать вращательные ускорения с помощью команды: 

Solution -> Define Loads -> Structural -> Inertia -

> Angular Accel -> Global 

 

Рис.84 
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На первом шаге это ускорение равно 10 (рис.84), на втором и третьем 

равно нулю.  

После проведения расчетов для перемещения по Z той же вершины 

пластины получим следующий переходный процесс: 

 

Рис.85 

Для перемещения по Z массы на конце балочного элемента получим 

следующий переходный процесс: 

 

Рис.86 
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Для деформированного и напряженного состояний после первого шага 

нагружения имеем следующую картину: 

 

Рис.87 

Для деформированного и напряженного состояний после второго шага 

нагружения имеем следующие картины: 

 

Рис.88 
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Рис.89 

Подобные расчеты могут быть полезны, например, при анализе 

переходных процессов в панелях солнечных батарей с концевой антенной 

при выполнении космическим аппаратом угловых маневров.  

Практическая важность рассмотренного примера также 

обуславливается совместным использованием разных типов конечных 

элементов. 
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§7. Спектральный анализ отклика конструкции 

 

Спектральный анализ позволяет получить зависимости максимальных 

значений откликов конструкции (перемещения, напряжения, скорости, 

ускорения, реакции) от внешних колебательных нагрузок. В спектральном 

анализе используются результаты модального анализа с известным спектром. 

Спектральный анализ главным образом используется вместо анализа 

переходных процессов для определения реакции конструкции на случайные 

или зависящие от времени нагрузки. Это в первую очередь касается 

землетрясений, ветровых нагрузок, действия океанских волн, влияния 

колебаний тяги реактивного двигателя и так далее. 

Спектральный анализ проводится на основе изучения отклика систем 

маятникового типа с одной степенью свободы на внешнее нагружение. 

Обычно подразумевается следующая ситуация. В каком-либо исследуемом 

узле системы располагают систему одностепенных маятников с различными 

собственными частотами, причем считается, что массы этих маятников 

пренебрежимо малы по сравнению с массой элемента и никак не влияют на 

его собственную динамику. После приложения внешнего нагружения 

система маятников вовлекается в колебательное движение, по параметрам 

которого определяются частоты откликов - частоты «отозвавшихся» 

маятников. 

Возможно проведение двух типов спектрального анализа: single-point 

response spectrum (SPRS) and multi-point response spectrum (MPRS).  

В «одноточечном» (SPRS) анализе определяется только одна 

спектральная кривая для внешнего воздействия, которое передается на 

конструкцию через граничные закрепления. Через каждый узел закрепления 

передается одно и тоже воздействие (рис. 90-а)). В «многоточечном» (MPRS) 

анализ, можно определять различные спектры внешнего воздействия на 

различные группы граничных закреплений (рис. 90-b).  
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Рис.90 

Возможен также анализ на основе метода ―Dynamic Design Analysis 

Method‖ (DDAM). Этот тип анализа основан на использовании эмпирических 

моделей, разработанных исследовательской лабораторией военно-морского 

флота США (The US Naval Research Laboratory Report NRL-1396) и 

предназначен для исследования процессов удара морских волн о борта 

судов

. 

Также пакет ANSYS позволяет проводить спектральный анализ при 

воздействии случайных колебательных процессов, - Power spectral density 

(PSD). Этот анализ используется для исследования случайных вибраций, в 

которых мгновенные величины реакции могут быть определены только 

функциями распределения вероятности. 

Рассмотрим проведение «одноточечного» анализа SPRS. Укрупненный 

план проведения SPRS содержит следующие действия:  

1. Построение расчетной модели. 

2. Проведение модального анализа (modal) и извлечение N 

собственных форм (мод). 

3. Вычисление частотного спектра (spectral). 

4. Разложение по собственным модам (expand). 

5. Комбинирование мод. 

6. Анализ результатов.  

 

Определение собственных форм колебаний (мод) конструкции 

требуется для разложения по ним решений (перемещений, а, следовательно, 

                                                 

 информация взята из системы помощи программы ANSYS 
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напряжений) и спектра собственных частот. В последствии из вычисленных 

N мод на шаге их комбинирования выбираются лишь те, которые вносят в 

решение «существенный» вклад, определяемый специальным численным 

порогом.  

1. Построение расчетной модели. 

Ресурс-ДК 

 

Рис.91 

Ключевые точки: 

NN X Y 

1 0.0 0.0 

2 0.7 0.0 

3 0.7 -0.05 

4 1.5 -0.05 

5 1.5 -3.05 

6 0.5 -3.05 

7 0.5 -8.05 

8 0.45 -8.05 

9 0.450 -2.5 

10 0.5 -2.5 

11 0.5 -3.0 

12 1.45 -3.0 

13 1.45 -0.1 

14 0.0 -0.1 

15 0.0 -8.05 
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Ключевые точки 1-14 предназначены для образования замкнутой 

фигуры – половины сечения корпуса КА. Точки 1 и 15 будут использованы 

для операции extrude для вращения этого профиля вокруг оси Y и получения 

тела вращения, моделирующего корпус КА. В итоге получаем следующее 

сечение КА и его корпус после вращения сечения. 

 

Рис.92 

 

Рис.93 
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Панели солнечных батарей (ПСБ) будем моделировать твердотельными 

параллелепипедами малой толщины. Правое крыло ПСБ будем формировать 

на ключевых точках главной диагонали {1.7, -1.05, 2}- {4.7, -0.95, -2}. 

Необходимо, конечно же, построить и левое симметричное крыло ПСБ.  

Крепление ПСБ к корпусу в нашем примере будем осуществлять 

«сквозной» твердотельной прямоугольной балкой с главной диагональю {1.9, 

-1.1, 0.1}- {-1.9, -0.9, -0.1}. 

После указанных построений получаем следующую модель КА. 

 

 

Рис.94 

Для корпуса КА, панелей ПСБ и балки их крепления будем 

использовать один и тот же тип конечных элементов SOLID92. Применим, 

однако, применим два различных материала: Preprocessor -> 

Material Props -> Material Models, 

где после задания свойств одного материала в собственном меню формы 

(рис.) добавляем еще один материал: Material -> New Model… 
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Рис.95 

Задаем модули Юнга, коэффициенты Пуассона и плотности материалов. 

Материал 1: EX=1e11, PRXY=0.3,  DENS=2500. 

Материал 2: EX=6e10, PRXY=0.2,  DENS=2000. 

Далее нужно построить конечно-элементную модель, причем так, 

чтобы в точках пересечения тел (корпус КА, ПСБ, балка крепления) 

использовались общие узлы, что означало бы монолитность цельной 

конструкции. Для этих целей можно предварительно выполнить операцию 

определения частичного перекрытия (совпадения, нахлеста) элементов 

конструкции: 

Preprocessor -> Modeling -> Operate -> Booleans -> 

Overlap -> Volumes -> Pick all 

После выполнения операции все построенные твердотельные элементы 

«разбились» на прилегающие друг к другу отдельные подэлементы с общими 

границами.  

Теперь строим конечные элементы. Пусть корпус КА и балка 

крепления ПСБ изготовлены из материала №1, а крылья ПСБ – из материала 

№2. Выберем предварительно в параметрах конечных элементов свойства 

материала №1:  
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Meshing -> Mesh Attributes -> Default Attribs –> All 

volumes 

 

 

Рис.96 

При этом всем телам назначается материал №1. Далее нужно переназначить 

материал для крыльев ПСБ: 

Meshing -> Mesh Attributes -> Default Attribs –> 

Picked volumes, мышью выбираем оба крыла ПСБ, ОК: 

 

 
Рис.97 

Строим сетку конечных элементов на корпусе: Meshing -> Mesh -> 

Volumes -> Free,  Pick all.  



 83 

 

Рис.98 

Причем в увеличенном масштабе можно проверить общность узлов на 

сопрягаемых телах конструкции: 

 

Рис.99 
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2. Проведение модального анализа (modal) 

Итак, расчетная модель создана, переходим к проведению 

спектрального анализа отклика, который начинается с модального анализа.  

Solution> Analysis Type> New Analysis, "Modal". 

Опции анализа: 
Solution> Analysis Type> Analysis Options.  

 

Рис.100 

Как видно из выбранных опций, мы собираемся вычислить 10 мод колебаний 

и все их использовать в разложениях решений (см. секцию MXPAND).  

Проведем анализ отклика конструкции на пульсации двигательной 

установки. Пульсации двигателя «сотрясают» КА через поверхность своего 

крепления к корпусу подобно тому, как сейсмическая нагрузка воздействует 

на здание через его фундамент. Мы не случайно сравнили воздействие 

двигателя с сейсмическими. Будем моделировать приложение 

пульсирующего воздействия посредством специального закрепления, на 

которое подается «сейсмическая» нагрузка с определенными амплитудами и 

частотами. Закрепим по всем степеням свободы узлы малой верхней 
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цилиндрической части, которая рассматривается нами как внешний срез 

сопла двигателя (Solution -> Define Loads -> Apply -> 

Structural -> Displacement -> On Areas). В последствии на это 

закрепление мы и подадим «сейсмическое» нагружение. Отметим, что 

использование сейсмического нагружения мы выдумали не сами. Так в 

ANSYS существует специальный метод «сейсмической тряски», 

разработанный как для исследования влияния на конструкцию 

землетрясений, так и вибраций корпусов ракет и летательных аппаратов от 

двигателей и других пульсирующих элементов. 

Выполним расчет: Solution> Solve> Current LS 

Ниже приводятся результаты для вычисленных мод (13, 49 моды). 

 

 

Рис.101 

3. Вычисление частотного спектра (spectral). 
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Проводим спектральный расчет: 

Solution -> Analysis Type -> New Analysis, "Spectrum" 

Задаем опции расчета, включающие выбор внешнего воздействия в виде 

«сейсмических ускорений» (Seismic accel) и направления этих пульсаций 

(Excitation direction: SEDX, SEDY, SEDZ): 

Solution -> Load Step Opts -> Spectrum -> Single 

Point -> Settings,  "Seismic accel" (параметры см. На рис.) 

 

Рис.102 

Определяем параметры внешнего «сейсмического» пульсирующего 

воздействия в виде кусочно-линейного спектра. Сначала задаются точки 

(абсциссы) для частот внешних пульсаций: 

Solution -> Load Step Opts -> Spectrum -> Single Point 

-> Freq Table.  

Сформируем следующие шесть частотных точек: 
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Рис.103 

Далее заполняем амплитуды (ординаты) для указанных частот спектра: 

Solution -> Load Step Opts -> Spectrum -> Single 

Point -> Spectr Values.  

Возьмем следующие амплитуды: 

 

Рис.104 

Запускаем расчет: Solution -> Solve -> Current LS.  

3. Разложение по собственным модам (expand). 

Выполним команды меню: 

 Solution> Analysis Type> New Analysis. > "Modal" OK.  

 Solution> Analysis Type> Expansion Pass.> ON (рис.) 
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Рис.105 

Solution > Load Step Opts > Expansion Pass > Single Expand > Expand Modes.  

 
Рис. 106 

Запустим расчет:      Solution> Solve> Current LS. 

4. Комбинирование мод. 

 Последовательно выполняем команды меню: 

Solution> Analysis Type> New Analysis> "Spectrum" OK.  

Solution> Analysis Type> Analysis Options (рис.107).  

 

Рис.107 
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Solution> Load Step Opts> Spectrum> Single Point> Mode Combine. > 

заполним форму (рис.108), ОК. 

 

Рис.108 

Запускаем расчет: Solution> Solve> Current LS.  

Просматриваем результаты: 

Main Menu > General Postproc > Results Summary: 

 

Рис.109 

Загружаем файл с результатами, сформированный системой ANSYS, для 

дальнейшего их использования: 
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Меню программы (верхнее Utility Menu)> File> Read Input From. Далее 

Выбираем (мышью в диалоге) файл с расширением mcom и имененм задачи, 

которое было назначено на начальном этапе (по умолчанию jobname.mcom ), 

OK. (рис.110) 

 

Рис.110 

В командной строке с клавиатуры вводим команду PRNSOL,DOF. После 

выполнения выводится результат команды (рис.111): выводятся значения 

перемещений в узлах модели. 

 

Рис.111 
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Для графического отображения возможных картин деформаций 

модели, изоповерхностей и пр. как и ранее воспользуемся графическим 

постпроцессором:  

General Postprocc -> Plot result -> Deformed Shape, 

General Postprocc -> Plot result -> Contour Plot 

 
 

 
Рис.112 
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Рис.113 

Для визуализации результатов можно также определить новую 

переменную, описывающую колебательный отклик конкретного узла по 

конкретному направлению. Определение новой переменной описывалось 

выше. В нашем случае переменная получит номер 2. Номер 1 зарезервирован 

для частоты (времени). 
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Чтобы построить спектр для этой переменной нужно обратиться в 

меню TimeHist Postpro -> Generate Spectrm и заполнить форму (рис.114) 

 

Рис.114 

Для спектра в нашем случае будет сформирована переменная 10 (номер 

10 мы определили сами), которая является спектром для переменной 2, а в 

качестве переменной для частоты указывается переменная номер 1. Далее, 

как и ранее можно построить график для переменной 10, т.е. отобразить 

спектр. Пример двух спектров откликов некоторых двух узлов приведен на 

рис. 115. 

 

Рис.115 
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Заключение 

 

 В настоящем электронном учебном пособии, выполненным в рамках 

электронного образовательного контента «Использование CAE-пакета 

ANSYS в задачах динамики космических конструкций (космическое 

машиностроение)», рассмотрены вопросы динамики конструкций с 

применением CAE-пакета конечно-элементного анализа ANSYS.  

Материал пособия включает описание методологии решения задач 

динамики конструкций, включая расчет статического напряженно-

деформированного состояния, анализ собственных форм и частот 

конструкции, гармонический анализ, анализ переходных процессов в 

конструкциях, спектральный анализ.  

Рассмотрен ряд конкретных практических примеров, в том числе 

проведен анализ напряженно-деформированного состояния створки 

головного обтекателя ракеты-носителя, анализ переходных процессов в 

панели солнечных батарей, определен спектральный отклик элементов 

космического аппарата на возмущение со стороны двигательной установки.  

Пособие предназначено для студентов (бакалавриата/ специалитета/ 

магистратуры), обучающихся по направлениям 160400 «ракетные комплексы 

и космонавтика», 161100 «Системы управления движением и навигация», 

151600 «Прикладная механика», а также будет полезно студентам других 

направлений подготовки и специальностей, связанных с проектированием и 

исследованием технических объектов и систем. 
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